[Warning] Creator 2.0.8 以下版本发布 Android 工程时,不要使用 NDK18

谢谢,不过我觉得 issue 的关闭在 issue 解决后关闭。有管理权限的,可以确认问题已解决,关闭 issue 没问题。

感觉在工作中你也是个不看产品文档的主儿

昨天才装看一次环境,用的2.1和NDK18 API Level 16编译报错。换成API Level 22就OK了,现在装环境简单太多,以前还得多装一个ant 现在装Androids studio就可以装SDK和NDK 不用搞系统变量

感谢提醒,我试着自己把安卓工程改到用NDK18,改到C++代码时已经完全不知道怎么改了,期待你们的Creator2.1

1赞

大佬 2.1是不是更新 Sprite组件的 type 的fillstart属性和fillRange属性了

不太了解,请参考 creator 的版本发布日志,到相关的帖子讨论

貌似自定义事件,无法跨语言吧

如果自定义事件能够跨脚本的话,还要那么辛辛苦苦的绑定脚本干嘛

现在android studio 出了 3.2 版,安装 之后,在SDK Manager 那里,只有NDK r18 ,这种 情况要怎么办?

原来lua是可以的,所以我 想当然了!!!

在 creator 的项目设置,配置自己下载的 ndk

https://developer.android.com/ndk/downloads/?hl=zh-cn

那个creator里面没有removeChildAt这个方法吗?类似数组的splice的方法有吗?求解啊 大佬

直接把 child.parent 设为 null 就可以了

/Applications/CocosCreator.app/Contents/Resources/cocos2d-x/cocos/scripting/js-bindings/jswrapper/Value.cpp:539: se::Object* se::Value::toObject() const: assertion "isObject()" failed

用的 r16 ndk,
能编译过,就是运行报错。

这个不代表是引擎的问题,你需要看下堆栈,可能是调用一个绑定接口,接口需要一个 Object 参数,但实际给错了

请问一下android4.4以及以下系统闪退有人遇到过跟我一样的情况吗 改ndk版本什么的都试过了还是不行

感谢大佬回答。。这个解决了,原本是想干嘛来着。。。好吧忘了。不过倒着遍历就解决了。child.parent=null...这样好像也很好用。。:grin:

反正现在是不敢随便乱升版本了,一个固定下来再说

请教一下,我的项目cocos可以打包安卓,用creator打包安卓老是编译失败咋回事呢,环境配置都是对的呢,我后来用一个空项目creator还是打包出错

我按照官网文档配置,打包不行还是编译失败