第一次安卓打包,求助!!!救救我这个小菜鸡吧

MAC inter
cocos编辑器版本2.4.5
Gradle版本6.1.1
Gradle插件版本4.0.0,
安卓版本:不会看。。。
构建:
image
sdk/ndk:
image
build APK的时候就会


清理缓存(clean/clean/file-inv)的时候这样

请问一下哪里出了问题,应该怎么改?

你是不是按照android studio的建议升级了gradle插件?我记得2.4.5gradle版本还在3.x

对,看到提示就升级了,那我应该怎么做
我同事的也是cocos2.4.5的,gradle版本和插件版本分别是,6.1.1/4.0.1他的好用
我这应该是差在哪里了,希望教我一下,谢谢:pray:

https://blog.asroads.com/post/d184577c.html

按照这个一步一步来。

1赞

刚看完一模一样。 :sweat:

卸载重新来一遍吧

版本回退 用这个版本
classpath ‘com.android.tools.build:gradle:3.5.0’
distributionUrl=https://services.gradle.org/distributions/gradle-5.4.1-all.zip

之前我遇见的这个报错是因为jni/cocosAndroid.mk 的cocos2djs_shared 没改成 cocos2djs